Delayed Notifications (DataDog, Slack, Webhooks, Pagerduty, etc)
Incident Report for Runscope
Resolved
DataDog ingestion performance issues have been resolved. Follow the DataDog status updates for more information https://status.datadoghq.com/
Posted about 1 month ago. Dec 11, 2018 - 12:59 PST
Monitoring
We have implemented a workaround to prevent slow DataDog API requests from delaying other notifications. We will continue to monitor until the DataDog performance issue is resolved.
Posted about 1 month ago. Dec 11, 2018 - 12:30 PST
Identified
We have identified an issue with the DataDog ingestion API. (See: https://status.datadoghq.com/ ) This is causing events sent to DataDog to time out and slowing down our notification queuing system. We are monitoring the delay and will deploy workarounds as needed. Customers using the DataDog integration may see data loss.
Posted about 1 month ago. Dec 11, 2018 - 11:48 PST
This incident affected: API Tests.